VS:SetItemClickable

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the specified item to generate events when clicked. Currently only static text and images are supported.

Remark: Use in the dialogs setup event handler. Changes the cursor if the mouse is over the item to indicate its clickability.

PROCEDURE SetItemClickable(
dialogID :LONGINT;
componentID :LONGINT;
clickable :BOOLEAN);
def vs.SetItemClickable(dialogID, componentID, clickable):
    return None

Parameters

dialogID LONGINT
componentID LONGINT
clickable BOOLEAN

Version

Availability: from Vectorworks 2010