VS:SetGradientSliderData

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the spot position, midpoint position and color of the specified gradient slider segment.

Note: you must use a variable, initialized to the segment index, to pass as a parameter. After the data has been set, this variable will contain the index of the segment, which may have changed because of the spot position specified.

PROCEDURE SetGradientSliderData(
dialogID :LONGINT;
componentID :LONGINT;
VAR segmentIndex :INTEGER;
spotPosition :REAL;
midpointPosition :REAL;
red :LONGINT;
green :LONGINT;
blue :LONGINT);
def vs.SetGradientSliderData(dialogID, componentID, segmentIndex, spotPosition, midpointPosition, red, green, blue):
    return segmentIndex

Parameters

dialogID LONGINT Index to the dialog layout that contains the gradient slider component.
componentID LONGINT Index to a specific gradient slider component.
segmentIndex INTEGER Segment for which to set the data.
spotPosition REAL Position of the segment's color marker relative to left-most point of the slider.
midpointPosition REAL Position of the segment's midpoint marker relative to color marker immediately to left.
red LONGINT Red component of the color spot's color.
green LONGINT Green component of the color spot's color.
blue LONGINT Blue component of the color spot's color.

Example

VectorScript

segmentIndex := 4;
SetGradientSliderData(dialogID, componentID, segmentIndex, 0.9, 0.5, 255, 255, 255);

Python


Version

Availability: from VectorWorks10.0