VS:SetEdgeBinding

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Binds edges of a dialog control to its parent. This function sets bindings to be fixed. To change any of them to be proportional, use SetProportionalBinding.

PROCEDURE SetEdgeBinding(
dialogID :LONGINT;
itemID :LONGINT;
boundToLeft :BOOLEAN;
boundToRight :BOOLEAN;
boundToTop :BOOLEAN;
boundToBottom :BOOLEAN);
def vs.SetEdgeBinding(dialogID, itemID, boundToLeft, boundToRight, boundToTop, boundToBottom):
    return None

Parameters

dialogID LONGINT
itemID LONGINT
boundToLeft BOOLEAN
boundToRight BOOLEAN
boundToTop BOOLEAN
boundToBottom BOOLEAN

Remarks

Binding to an edge indicates that the control will maintain a predictable distance from one of its sides to the corresponding side of its parent. Bindings can be either fixed or proportional. Fixed bindings maintain a constant distance from their parent. Proportional bindings maintain a distance that is a ratio of the initial position to the width (or height, as appropriate) of the parent.

Version

Availability: from VectorWorks12.0

See Also

VS Functions:

VS:CreateResizableLayout | VS:SetProportionalBinding

VS Functions:

[[VS:CreateResizableLayout]]

| [[VS:SetProportionalBinding]]