VS:SetDefaultTexMapN

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Set the object to have default texture mapping info. Texture resource being used is set with SetTextureRef. This routine replaces SetDefaultTexMap with version 2010 and above.

PROCEDURE SetDefaultTexMapN(
h :HANDLE;
texPartID :LONGINT;
texLayerID :LONGINT);
def vs.SetDefaultTexMapN(h, texPartID, texLayerID):
    return None

Parameters

h HANDLE The textured object
texPartID LONGINT The texture part ID
texLayerID LONGINT The texture layer ID, 0 for base, >0 for decals

Version

Availability: from Vectorworks 2010