VS:SetDLComponentUsePenClassAttr

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the useclass attributes flags of the left and right side pens of the component at index in the Double Line Preferences.

FUNCTION SetDLComponentUsePenClassAttr(
index :INTEGER;
leftPenUseClassAttr :BOOLEAN;
rightPenUseClassAttr :BOOLEAN) : BOOLEAN;
def vs.SetDLComponentUsePenClassAttr(index, leftPenUseClassAttr, rightPenUseClassAttr):
    return BOOLEAN

Parameters

index INTEGER The index of the component.
leftPenUseClassAttr BOOLEAN Whether or not the component will use class attributes for its left pen.
rightPenUseClassAttr BOOLEAN Whether or not the component will use class attributes for its right pen.

Remarks

CJG 3-23-07

Version

Availability: from VectorWorks13.0

See Also

VS Functions:

VS:GetDLComponentUsePenClassAttr

VS Functions: [[VS:GetDLComponentUsePenClassAttr]]