VS:SetDLComponentPenStyles

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the left and right pen styles for the component at index in the Double Line Preferences.

FUNCTION SetDLComponentPenStyles(
index :INTEGER;
penStyleLeft :INTEGER;
penStyleRight :INTEGER) : BOOLEAN;
def vs.SetDLComponentPenStyles(index, penStyleLeft, penStyleRight):
    return BOOLEAN

Parameters

index INTEGER The index of the component.
penStyleLeft INTEGER The pen style of the component's left line. Positive values for patterns, negative values for dash styles.
penStyleRight INTEGER The pen style of the component's right line. Positive values for patterns, negative values for dash styles.

Remarks

CJG 6-27-06

Version

Availability: from VectorWorks12.5

See Also

VS Functions:

VS:GetDLComponentPenStyles

VS Functions: [[VS:GetDLComponentPenStyles]]