VS:SetComponentPenWeights

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the left and right pen weights for a component in an object.

FUNCTION SetComponentPenWeights(
obj :HANDLE;
componentIndex :INTEGER;
leftPenWeight :INTEGER;
rightPenWeight :INTEGER) : BOOLEAN;
def vs.SetComponentPenWeights(obj, componentIndex, leftPenWeight, rightPenWeight):
    return BOOLEAN

Parameters

obj HANDLE The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
componentIndex INTEGER The index of the component.
leftPenWeight INTEGER The pen weight of the component's left line.
rightPenWeight INTEGER The pen weight of the component's right line.

Remarks

VW2011: It seems that the right line doesn't get adjusted...

Version

Availability: from VectorWorks 12.0

See Also

VS Functions:

VS:GetComponentPenWeights

VS Functions: [[VS:GetComponentPenWeights]]