VS:SetComponentFunction

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the function of a component in an object.

FUNCTION SetComponentFunction(
object :HANDLE;
componentIndex :INTEGER;
func :INTEGER) : BOOLEAN;
def vs.SetComponentFunction(object, componentIndex, func):
    return BOOLEAN

Parameters

object HANDLE The object. Can be a wall, round wall, slab, roof face, roof, Wall Style, Slab Style, Roof Style, the Wall Preferences, the Slab Preferences, or the Roof Preferences.
componentIndex INTEGER The index of the component.
func INTEGER The function of the component. 0 - Other 1 - Load-Bearing 2 - Insulation 3 - Inner Finish 4 - Outer Finish 5 - Air Gap

Version

Availability: from Vectorworks 2018

See Also

VS Functions:

VS:GetComponentFunction

VS Functions: [[VS:GetComponentFunction]]