VS:SetComponentAutoBoundEdgeOffset

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the auto-bound edge offset of a component in an object.

FUNCTION SetComponentAutoBoundEdgeOffset(
obj :HANDLE;
componentIndex :INTEGER;
autoBoundEdgeOffset :INTEGER) : BOOLEAN;
def vs.SetComponentAutoBoundEdgeOffset(obj, componentIndex, autoBoundEdgeOffset):
    return BOOLEAN

Parameters

obj HANDLE The object. Can be a slab, Slab Style, or the Slab Preferences.
componentIndex INTEGER The index of the component.
autoBoundEdgeOffset INTEGER The auto-bound edge offset. 0 - Inner face, 1 - Outer face of inner component, 2 - Inner face of core, 3 - Center of core, 4 - Outer face of core, 5 - Inner face of outer component, 6 - Outer face

Version

Availability: from Vectorworks 2011

See Also

VS Functions:

VS:GetComponentAutoBoundEdgeOffset

VS Functions: [[VS:GetComponentAutoBoundEdgeOffset]]