VS:SetCompUseClassLPW

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the use class pen weight for left pen flag of a component in an object.

FUNCTION SetCompUseClassLPW(
object :HANDLE;
componentIndex :INTEGER;
useClassPenWeightForLeftPen :BOOLEAN) : BOOLEAN;
def vs.SetCompUseClassLPW(object, componentIndex, useClassPenWeightForLeftPen):
    return BOOLEAN

Parameters

object HANDLE The object. Can be a wall, round wall, slab, roof face, roof, Wall Style, Slab Style, Roof Style, the Wall Preferences, the Slab Preferences, or the Roof Preferences.
componentIndex INTEGER The index of the component.
useClassPenWeightForLeftPen BOOLEAN Whether or not the component will use class attributes for its left pen weight.

Version

Availability: from Vectorworks 2016

See Also

VS Functions:

VS:GetCompUseClassLPW

VS Functions: [[VS:GetCompUseClassLPW]]