VS:ScreenPlanePtToPlanarPt

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Projects a 2D point from the screen plane onto the specified plane.

PROCEDURE ScreenPlanePtToPlanarPt(
refID :LONGINT;
pt2D :REAL;
VAR outPt :REAL);
def vs.ScreenPlanePtToPlanarPt(refID, pt2D):
    return outPt

Parameters

refID LONGINT Reference ID of the plane.
pt2D REAL Input the 2D point on the screen.
outPt REAL Output the 2D point on the plane.

Version

Availability: from Vectorworks 2011