VS:RoundWall

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure RoundWall creates a counter-clockwise round wall.

PROCEDURE RoundWall(
centerPtX,centerPtY :REAL;
startPtX,startPtY :REAL;
endPtX,endPtY :REAL);
def vs.RoundWall(centerPt, startPt, endPt):
    return None

Parameters

centerPt REAL Center point of wall arc.
startPt REAL Start point of wall arc.
endPt REAL End point of wall arc.

Remarks

Creates a round wall the that is centered on the arc specified by the the three input points.

Example

VectorScript

PROCEDURE Example;
VAR
x1, y1, x2, y2, x3, y3 :REAL;
lineHandle :HANDLE;
BEGIN
GetPt(x1, y1);
GetPtL(x1, y1, x2, y2);
MoveTo(x1, y1);
LineTo(x2, y2);
lineHandle := LNewObj;
GetPtL(x2, y2, x3, y3);
IF lineHandle <> NIL THEN DelObject(lineHandle);
RoundWall(x1, y1, x2, y2, x3, y3);
END;
RUN(Example);

Python


Version

Availability: from MiniCAD7.0

See Also

VS Functions:

VS:Wall

VS Functions: [[VS:Wall]]