VS:ProgressDlgStart

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Start a progress context. This defines progress percentage and loop count for ProgressDlgYield calls. LoopCount is fit in the Percentage of the progress

PROCEDURE ProgressDlgStart(
Percentage :REAL;
LoopCount :LONGINT);
def vs.ProgressDlgStart(Percentage, LoopCount):
    return None

Parameters

Percentage REAL
LoopCount LONGINT

Example

Samples can be found at VS:Progress Dialog.

Version

Availability: from Vectorworks 2015

See Also

VS:ProgressDlgOpen | VS:ProgressDlgClose | VS:ProgressDlgSetTopMsg | VS:ProgressDlgSetBotMsg | VS:ProgressDlgSetMeter | VS:ProgressDlgStart | VS:ProgressDlgEnd | VS:ProgressDlgHasCancel | VS:ProgressDlgYield

[[VS:ProgressDlgOpen]] | [[VS:ProgressDlgClose]] | [[VS:ProgressDlgSetTopMsg]] | [[VS:ProgressDlgSetBotMsg]] | [[VS:ProgressDlgSetMeter]] | [[VS:ProgressDlgStart]] | [[VS:ProgressDlgEnd]] | [[VS:ProgressDlgHasCancel]] | [[VS:ProgressDlgYield]]