VS:Perim

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

DEPRECATED after Vectorworks2012. See PerimN for a replacement.

Returns the perimeter of an object. If more than one object matches the search criteria, the function will return the sum of the matching objects' perimeters.

FUNCTION Perim(
c :CRITERIA) : REAL;
def vs.Perim(c):
    return REAL

Parameters

c CRITERIA Search criteria.

Example

VectorScript

PerimValue := Perim(C='Fence');
{returns the total perimeter of all objects in the class 'Fence'}

Python


Version

Availability: from All Versions

Deprecated: Vectorworks 2012