VS:NurbsCurveEvalPt

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

This procedure determines the point on the nurbs curve at the given u value in the indexed piece.

The index is zero based (0 to number of knots - 1). The u value can range from 0 to the value of the last knot in the curve segment.

PROCEDURE NurbsCurveEvalPt(
objectHd :HANDLE;
index :LONGINT;
u :REAL;
VAR pX,pY,pZ :REAL);
def vs.NurbsCurveEvalPt(objectHd, index, u):
    return p

Parameters

objectHd HANDLE Handle to a NURBS curve.
index LONGINT Segment of curve to be queried.
u REAL Parameter between the minimum and maximum knot value.
p REAL Location of the u point on the curve.

Version

Availability: from VectorWorks9.5

See Also

VS Functions:

VS:NurbsKnot | VS:NurbsNumKnots

VS Functions:

[[VS:NurbsKnot]]

| [[VS:NurbsNumKnots]]