VS:Num2Str

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Function Num2Str converts a REAL value to a string and returns the value.

Parameter decPlace has a range of -1 to 9; if -1 is specified, the value will be returned in scientific notation.

FUNCTION Num2Str(
decPlace :INTEGER;
v :REAL) : STRING;
def vs.Num2Str(decPlace, v):
    return STRING

Parameters

decPlace INTEGER Number of decimal places.
v REAL Numeric value.

Remarks

_c_, 2015.05.23: You can also use VS:Concat to convert numbers to strings, but it uses exclusively a dot "." as symbol for the decimal marker, because it outputs the number as seen from inside VS, I suppose. See further comments on the page VS:Concat.

The parameter decPlace can be the following values:

Value Meaning Sample
positive round-up the value 10.56 -> 10.6 (1 decimal place)
0 round-up the value 10.56 -> 11
-1 Use scientific notation (9 decimal places) 10.56 -> 1.056000000e+001
-2 Use scientific notation (15 decimal places) 10.56 -> 1.056000000000000e+001

Example

VectorScript

oldnumValue := 232.5148;
newStrValue := Num2Str(3, oldnumValue);
{ --> '232.515' if your system is american }
{ --> '232,515' if your system is metric }

Python


Version

Availability: from All Versions