VS:Name2Index

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Function Name2Index returns the internal index number for the specified object.

FUNCTION Name2Index(
name :STRING) : LONGINT;
def vs.Name2Index(name):
    return LONGINT

Parameters

name STRING Name of object.

Remarks

Returns the internal index for the object associated with the specified name.

(Joel Sciamma 2006.08.11): If the name does not exist, Name2Index returns zero.

Example

VectorScript

NameIndex := Name2Index('objectName');

Python


Version

Availability: from VectorWorks 8.0

See Also

VS Functions:

VS:SetSkylight | VS:CreateSkylight | VS:AddCavity

VS Functions:

[[VS:SetSkylight]] | [[VS:CreateSkylight]]

| [[VS:AddCavity]]