VS:MoveWallByOffset

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Available in Architect only. Moves the wall perpendicular to its definition line by the specified offset and maintains all wall connections. Wall movement may be constrained by the surrounding geometry so the actual amount of the offset is returned.

PROCEDURE MoveWallByOffset(
theWall :HANDLE;
VAR offset :REAL);
def vs.MoveWallByOffset(theWall, offset):
    return offset

Parameters

theWall HANDLE A handle to the wall to move.
offset REAL The distance to move the given wall. Negative offsets move the wall to the left and positive offsets move the wall to the right. The actual amount the wall was moved is returned in this field.

Return Value

The actual amount the wall was moved is passed back in the offset parameter.

Version

Availability: from VectorWorks10.0