VS:MakePolyline

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Creates a polyline using inSourceObject. inSourceObject is unchanged.

FUNCTION MakePolyline(
inSourceObject :HANDLE) : HANDLE;
def vs.MakePolyline(inSourceObject):
    return HANDLE

Parameters

inSourceObject HANDLE The 2D object from which to make a polyline.

Return Value

A polyline representation of inSourceObject.

Remarks

Creates a polyline from inSourceObject. inSourceObject is unchanged.


This routine does not delete inSourceObject; also it creates its returned object not as the last object in the active layer, but immediately after inSourceObject in the stacking order, so if you delete inSourceObject, you will have "replaced" it.

Example

VectorScript

PROCEDURE Example;
VAR
h,h2:HANDLE;
BEGIN
h:=FSActLayer;
h2 := MakePolyline(h);
DelObject(h);
END;
RUN(Example);

Python


Version

Availability: from VectorWorks10.1