VS:IsValidWSRange

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns whether the specified range is within the valid range of the referenced worksheet.

FUNCTION IsValidWSRange(
worksheet :HANDLE;
topRow :INTEGER;
leftColumn :INTEGER;
bottomRow :INTEGER;
rightColumn :INTEGER) : BOOLEAN;
def vs.IsValidWSRange(worksheet, topRow, leftColumn, bottomRow, rightColumn):
    return BOOLEAN

Parameters

worksheet HANDLE Handle to worksheet.
topRow INTEGER Top row of target range.
leftColumn INTEGER Leftmost column of target range.
bottomRow INTEGER Bottom row of target range.
rightColumn INTEGER Rightmost column of target range.

Return Value

A BOOLEAN value indicating whether the range is valid.

Remarks

Determines if specified range is valid for the specified worksheet.

NOTE: A determination that a range is valid only means that the specified range falls within a range of 0 to the current number of worksheet rows and 0 to the current number of worksheet columns. A valid range does not imply that every worksheet SDK function will accept that range. The user should always note any specific cell and cell range restrictions of a call they may use.

Version

Availability: from VectorWorks9.0