VS:InsertSymbol

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure InsertSymbol places a specified symbol into a wall.

PROCEDURE InsertSymbol(
offsetDistance :REAL;
heightDistance :REAL;
flipped :BOOLEAN;
right :BOOLEAN;
capped :BOOLEAN;
symbolName :STRING);
def vs.InsertSymbol(offsetDistance, heightDistance, flipped, right, capped, symbolName):
    return None

Parameters

offsetDistance REAL Offset distance from wall start.
heightDistance REAL Elevation of symbol.
flipped BOOLEAN Flip orientation of symbol.
right BOOLEAN Left-right orientation of symbol.
capped BOOLEAN Cap wall breaks.
symbolName STRING Name of symbol to be inserted in wall.

Example

VectorScript

MoveTo(3,1);
WallTo(5',5');
InsertSymbol(1',False,False,True,'Door');
{inserts the symbol 'Door' at 1' from the start point of the last wall segment}

Python


Version

Availability: from MiniCAD4.0

See Also

VS Functions:

VS:AddSymToWall | VS:AddSymToWallEdge

VS Functions:

[[VS:AddSymToWall]]

| [[VS:AddSymToWallEdge]]