VS:HWidth

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Function HWidth returns the width of the referenced object.

FUNCTION HWidth(
h :HANDLE) : REAL;
def vs.HWidth(h):
    return REAL

Parameters

h HANDLE Handle to object.

Remarks

Observed in 2021: Despite the OIP Width and Height fields flipping values when an object such as a rectangle is rotated 90/-90 degrees, vs.HWidth and vs.HHeight will always return the initial width and height values of the unrotated object, which can lead to unexpected values being returned in some instances. Unsure if this would be considered a bug or a feature...? -AMH (2021.06.26)

Example

VectorScript

w:=HWidth(HandleToObj); 

Python


Version

Availability: from All Versions