VS:GetWallCompEndPts

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the end points of a wall component.

PROCEDURE GetWallCompEndPts(
wall :HANDLE;
componentIndex :INTEGER;
VAR leftPoint :POINT;
VAR centerPoint :POINT;
VAR rightPoint :POINT);
def vs.GetWallCompEndPts(wall, componentIndex):
    return (leftPoint, centerPoint, rightPoint)

Parameters

wall HANDLE The wall or round wall
componentIndex INTEGER The component index
leftPoint POINT Returns the left end point of the component
centerPoint POINT Returns the center end point of the component
rightPoint POINT Returns the right end point of the component

Return Value

None

Version

Availability: from Vectorworks 2015

See Also

VS Functions:

VS:GetWallCompStartPts

VS Functions: [[VS:GetWallCompStartPts]]