VS:GetWallCapsOffsets

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Get the wall's caps' offsets.

PROCEDURE GetWallCapsOffsets(
theWall :HANDLE;
VAR leftCapLeftOffset :REAL;
VAR leftCapRightOffset :REAL;
VAR rightCapLeftOffset :REAL;
VAR rightCapRightOffset :REAL);
def vs.GetWallCapsOffsets(theWall):
    return (leftCapLeftOffset, leftCapRightOffset, rightCapLeftOffset, rightCapRightOffset)

Parameters

theWall HANDLE The wall.
leftCapLeftOffset REAL Returns the left offset of the left wall cap.
leftCapRightOffset REAL Returns the right offset of the left wall cap.
rightCapLeftOffset REAL Returns the left offset of the right wall cap.
rightCapRightOffset REAL Returns the right offset of the right wall cap.

Remarks

CJG 6-27-06

Version

Availability: from VectorWorks12.5

See Also

VS Functions:

VS:SetWallCapsOffsets

VS Functions: [[VS:SetWallCapsOffsets]]