VS:GetWallCapAttributesType

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the wall cap attributes type of a wall or round wall. The wall cap attributes type determines whether the wall caps have the wall line attributes or the component lines attributes. If they have the component lines attributes, each wall component is capped with its own left line attributes.

FUNCTION GetWallCapAttributesType(
wall :HANDLE) : INTEGER;
def vs.GetWallCapAttributesType(wall):
    return INTEGER

Parameters

wall HANDLE The handle to the wall or round wall.

Return Value

The wall cap attributes type.


0 - The wall cap attributes are the wall line attributes
1 - The wall cap attributes are the wall component lines attributes

Version

Availability: from Vectorworks 2010

See Also

VS Functions:

VS:SetWallCapAttributesType

VS Functions: [[VS:SetWallCapAttributesType]]