VS:GetWSRowHLockState

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the lock state of a row in the referenced worksheet

Note: If a row height is locked, the row will not automatically resize to fit the contents of the cells when text is entered.

PROCEDURE GetWSRowHLockState(
worksheet :HANDLE;
row :INTEGER;
VAR lockState :BOOLEAN);
def vs.GetWSRowHLockState(worksheet, row):
    return lockState

Parameters

worksheet HANDLE Handle to worksheet
row INTEGER Worksheet row index
lockState BOOLEAN Row Height lock state ( returns TRUE is row height is locked ; FALSE otherwise)

Example

VectorScript

{Gets the lock state of the fifth row in the specified worksheet}
GetWSRowHLockState(sheet,5,lockstate);

Python

lockstate = vs.GetWSRowHLockState(sheet,5)

Version

Availability: from VectorWorks12.0