VS:GetTextureShader

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Function GetTextureShader returns the LightWorks internal property reference ID for the shader attached to the referenced texture.

FUNCTION GetTextureShader(
texture :HANDLE) : LONGINT;
def vs.GetTextureShader(texture):
    return LONGINT

Parameters

texture HANDLE Handle to texture.

Remarks

Returns LightWorks internal property ref for the shader attached to this texture.

Version

GetTextureShader is obsolete as of VectorWorks9.0


Availability: from VectorWorks8.0