VS:GetTexMapInt

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Get map info for specific part of object. partID is texture part, overall is 3. Selector should be1, to return the texture map type integer.

FUNCTION GetTexMapInt(
h :HANDLE;
partID :LONGINT;
selector :INTEGER) : INTEGER;
def vs.GetTexMapInt(h, partID, selector):
    return INTEGER

Parameters

h HANDLE
partID LONGINT
selector INTEGER

Return Value

kPlaneSpace = 0;
kSphereSpace = 1;
kCylinderSpace = 2;
kAlgorithmicSpace = 3; {Space that wraps around the object most}

Algorithmic means either the "perimeter" or "roof" mapping type.

Version

Availability: from Vectorworks 14.0. Deprecated from Vectorworks 15.0.

See Also

GetTexMapIntN, SetTexMapIntN

[[VS:GetTexMapIntN|GetTexMapIntN]], [[VS:SetTexMapIntN|SetTexMapIntN]]