VS:GetStoryBelow

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the Story below the indicated Story. Returns NULL if there is none. If passed a NULL handle, returns the bottom-most Story in the current drawing.

FUNCTION GetStoryBelow(
story :HANDLE) : HANDLE;
def vs.GetStoryBelow(story):
    return HANDLE

Parameters

story HANDLE The indicated Story for which the Story below it is desired

Return Value

The Story below the indicated Story, or NULL if there is none. If a NULL handle is passed in, the bottom-most Story in the current drawing.

Example

VAR

baseStory:HANDLE;
storyBelow:HANDLE;

BEGIN

baseStory := GetStoryOfLayer(ActLayer);
storyBelow := StoryBelow(baseStory);

Version

Availability: from Vectorworks 2012

See Also

VS Functions:

VS:GetStoryAbove | VS:GetNumStories | VS:GetStoryOfLayer

VS Functions:

[[VS:GetStoryAbove]] | [[VS:GetNumStories]]

| [[VS:GetStoryOfLayer]]