VS:GetSelectedChoiceInfo

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the index of the selected item and the text of the selected item in a menu.

PROCEDURE GetSelectedChoiceInfo(
dialogID :LONGINT;
componentID :LONGINT;
startIndex :INTEGER;
VAR outSelectedIndex :INTEGER;
VAR outSelectedChoiceText :STRING);
def vs.GetSelectedChoiceInfo(dialogID, componentID, startIndex):
    return (outSelectedIndex, outSelectedChoiceText)

Parameters

dialogID LONGINT The dialog identifier given by CreateLayout or CreateResizableLayout
componentID LONGINT The identifier for the component that contains the choices.
startIndex INTEGER The index at which to start looking for a selected item.
outSelectedIndex INTEGER The index of the selected item or -1 if there is no selected item.
outSelectedChoiceText STRING The text of the selected item if it was found, otherwise this parameter is unchanged from when this function was called.

Version

Availability: from Vectorworks 2010