VS:GetProjection

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the projection index from the specified layer.

FUNCTION GetProjection(
theyLayer :HANDLE) : INTEGER;
def vs.GetProjection(theyLayer):
    return INTEGER

Parameters

theyLayer HANDLE Layer which the projection is returned for.

Return Value

Projection values:

  • 0: Orthogonal
  • 1: Perspective
  • 2: Cavalier Oblique 45
  • 3: Cavalier Oblique 30
  • 4: Cabinet Oblique 45
  • 5: Cabinet Oblique 30
  • 6: Plan
  • 7: Section
  • 8: Section Plus

Version

Availability: from VectorWorks 13.0

See Also

VS:ActLayer

[[VS:ActLayer]]