VS:GetPenBack

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure GetPenBack returns the pen (pattern) background color of the referenced object. RGB values are in the range of 0~65535.

PROCEDURE GetPenBack(
h :HANDLE;
VAR red :LONGINT;
VAR green :LONGINT;
VAR blue :LONGINT);
def vs.GetPenBack(h):
    return (red, green, blue)

Parameters

h HANDLE Handle to object.
red LONGINT Returns RGB color component value.
green LONGINT Returns RGB color component value.
blue LONGINT Returns RGB color component value.

Example

VectorScript

PROCEDURE Example;
VAR
h :HANDLE;
r, g, b :LONGINT;
BEGIN
h := FSActLayer;
GetPenBack(h, r, g, b);
Message('r= ', r, ' g= ', g, ' b= ', b);
END;
RUN(Example);

Python

def example():
	h = vs.FSActLayer()
	r, g, b = vs.GetPenBack(h)
	vs.Message('r= ', r, ' g= ', g, ' b= ', b)

example()

Version

Availability: from MiniCAD6.0

See Also

VS Functions: VS:RGBToColorIndex | VS:ColorIndexToRGB | VS:GetFillFore | VS:GetFillBack | VS:GetPenFore

VS Functions: [[VS:RGBToColorIndex]] | [[VS:ColorIndexToRGB]] | [[VS:GetFillFore]] | [[VS:GetFillBack]] | [[VS:GetPenFore]]