VS:GetParameterOnNurbsCurve

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Given a NURBS curve handle and a point (in world space), this function returns the parameter of the point obtained by projecting the input point. The function also returns the index of the piece in the piecewise NURBS curve on which the projected point lies.

FUNCTION GetParameterOnNurbsCurve(
h :HANDLE;
pointX,pointY,pointZ :REAL;
VAR parameter :REAL;
VAR index :LONGINT) : BOOLEAN;
def vs.GetParameterOnNurbsCurve(h, point):
    return (BOOLEAN, parameter, index)

Parameters

h HANDLE
point REAL
parameter REAL
index LONGINT

Version

Availability: from VectorWorks10.0