VS:GetObjectVariableLongInt

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the value of a VectorWorks object property. Used with properties returning a LONGINT value.

For specific object selector index values, see the Appendix.

FUNCTION GetObjectVariableLongInt(
h :HANDLE;
index :INTEGER) : LONGINT;
def vs.GetObjectVariableLongInt(h, index):
    return LONGINT

Parameters

h HANDLE Handle to object.
index INTEGER Object property index.

Return Value

Returns the value of the property as a LONGINT value.

Example

VectorScript

p:= GetObjectVariableLongInt(h,579);

Python

p = vs.GetObjectVariableLongInt(h,579)

Version

Availability: from VectorWorks9.0