VS:GetNumHoles

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the number of openings in the referenced polyline.

FUNCTION GetNumHoles(
inPolyline :HANDLE;
VAR outNumHoles :INTEGER) : BOOLEAN;
def vs.GetNumHoles(inPolyline):
    return (BOOLEAN, outNumHoles)

Parameters

inPolyline HANDLE Handle to polyline.
outNumHoles INTEGER The number of openings in the polyline object.

Remarks

This function never returns FALSE regardless of the object type of "inPolyline" or whether "inPolyline" has holes.

It will only return FALSE on "inPolyine" = NIL.

Version

Availability: from VectorWorks9.0

See Also

VS Functions:

VS:GetHole

VS Functions: [[VS:GetHole]]