VS:GetLocalizedPluginChoice

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns true with outChoice as specified by inPluginName, inParameterName and inChoiceIndex. Each of the input names are universal names.

FUNCTION GetLocalizedPluginChoice(
inPluginName :STRING;
inParameterName :STRING;
inChoiceIndex :INTEGER;
VAR outChoice :STRING) : BOOLEAN;
def vs.GetLocalizedPluginChoice(inPluginName, inParameterName, inChoiceIndex):
    return (BOOLEAN, outChoice)

Parameters

inPluginName STRING The universal name of the plug-in.
inParameterName STRING The universal name of the parameter.
inChoiceIndex INTEGER The index of the requested choice. ( range is 1 to n)
outChoice STRING The requested choice string.

Return Value

Returns true if the function call succeeded.

Version

Availability: from VectorWorks10.0

See Also

VS Functions:

VS:GetLocalizedPluginName

VS Functions: [[VS:GetLocalizedPluginName]]