VS:GetLineAttributeData

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Get the current choices for the combined line style and line weight dialog control. The line style value is an index and the line weight value is in mils.

PROCEDURE GetLineAttributeData(
dialogID :LONGINT;
itemID :LONGINT;
VAR lineStyle :INTEGER;
VAR lineWeight :INTEGER);
def vs.GetLineAttributeData(dialogID, itemID):
    return (lineStyle, lineWeight)

Parameters

dialogID LONGINT
itemID LONGINT
lineStyle INTEGER
lineWeight INTEGER

Version

Availability: from VectorWorks12.0