VS:GetLS

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Use GetLSN instead.

Function GetLS returns the line style of the referenced object.

FUNCTION GetLS(
h :HANDLE) : INTEGER;
def vs.GetLS(h):
    return INTEGER

Parameters

h HANDLE Handle to object.

Remarks

_c_ 2016.02.29: This is deprecated and returns always -1 as of VW 2016.

Example

VectorScript

lStyleValue := GetLS(handleToObject);

Python

lStyleValue = vs.GetLS(handleToObject)

Version

Availability: from All Versions, deprecated from Vectorworks 2013

See Also

GetLSN from Vectorworks 2013

[[VS:GetLSN|GetLSN]] from Vectorworks 2013