VS:GetDashStyleName

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Retrieves the dash style name of the specified dash style index.

FUNCTION GetDashStyleName(
DashStyleIndex :INTEGER) : STRING;
def vs.GetDashStyleName(DashStyleIndex):
    return STRING

Parameters

DashStyleIndex INTEGER The the index of the dash style.

Return Value

Name of the dash style specified by the index.

Remarks

_c_, (2016.03.01): The dash style index required is relative to the dash style list, not the name list. Use VS:GetDashStyle or VS:GetDashStyleIndex to obtain it. Analogically, the dash style name returned is the name in the dash style list (you set it with VS:SetDashStyleName), not the name list. This can be diverging.

dashStyleName := GetDashStyleName(GetDashStyleIndex(TRUE, 1, 0.12, 0.03));
{ should return 'ISO-02 Dashed' or its localized name, if a style with these pairs exists
in the active document, otherwise it creates one with a generic name }

Version

Availability: from Vectorworks 2011

See Also

VS Functions:

VS:SetDashStyleName

VS Functions: [[VS:SetDashStyleName]]