VS:GetComponentWallTopOffset

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the offset from wall top of a component in an object.

FUNCTION GetComponentWallTopOffset(
obj :HANDLE;
componentIndex :INTEGER;
VAR offsetFromWallTop :REAL) : BOOLEAN;
def vs.GetComponentWallTopOffset(obj, componentIndex):
    return (BOOLEAN, offsetFromWallTop)

Parameters

obj HANDLE The object. Can be a wall, round wall, Wall Style, or the Wall Preferences.
componentIndex INTEGER The index of the component.
offsetFromWallTop REAL Returns the offset from wall top of the component.

Version

Availability: from Vectorworks 2011

See Also

VS Functions:

VS:SetComponentWallTopOffset

VS Functions: [[VS:SetComponentWallTopOffset]]