VS:GetComponentTexture

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the texture of a component in an object.

FUNCTION GetComponentTexture(
obj :HANDLE;
componentIndex :INTEGER;
VAR texture :LONGINT) : BOOLEAN;
def vs.GetComponentTexture(obj, componentIndex):
    return (BOOLEAN, texture)

Parameters

obj HANDLE The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
componentIndex INTEGER The index of the component.
texture LONGINT Returns the ref number of the texture. 0 for no texture. -1 for class texture.

Version

Availability: from Vectorworks 2011

See Also

VS Functions:

VS:SetComponentTexture

VS Functions: [[VS:SetComponentTexture]]