VS:GetComponentPenWeights

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the pen weights of the left and right sides of a component in an object.

FUNCTION GetComponentPenWeights(
obj :HANDLE;
componentIndex :INTEGER;
VAR leftPenWeight :INTEGER;
VAR rightPenWeight :INTEGER) : BOOLEAN;
def vs.GetComponentPenWeights(obj, componentIndex):
    return (BOOLEAN, leftPenWeight, rightPenWeight)

Parameters

obj HANDLE The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
componentIndex INTEGER The index of the component.
leftPenWeight INTEGER Returns the pen weight of the component's left line.
rightPenWeight INTEGER Returns the pen weight of the component's right line.

Version

Availability: from VectorWorks 12.0

See Also

VS Functions:

VS:SetComponentPenWeights

VS Functions: [[VS:SetComponentPenWeights]]