VS:GetComponentPenColors

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the colors of the pens of a component in an object.

FUNCTION GetComponentPenColors(
obj :HANDLE;
componentIndex :INTEGER;
VAR leftPenForeColor :INTEGER;
VAR leftPenBackColor :INTEGER;
VAR rightPenForeColor :INTEGER;
VAR rightPenBackColor :INTEGER) : BOOLEAN;
def vs.GetComponentPenColors(obj, componentIndex):
    return (BOOLEAN, leftPenForeColor, leftPenBackColor, rightPenForeColor, rightPenBackColor)

Parameters

obj HANDLE The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
componentIndex INTEGER The index of the component.
leftPenForeColor INTEGER Returns the fore color of the left pen.
leftPenBackColor INTEGER Returns the back color of the left pen.
rightPenForeColor INTEGER Returns the fore color of the right pen.
rightPenBackColor INTEGER Returns the back color of the right pen.

Version

Availability: from VectorWorks 2008

See Also

VS Functions:

VS:SetComponentPenColors

VS Functions: [[VS:SetComponentPenColors]]