VS:GetComponentFillColors

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the fore and back fill colors of a component in an object.

FUNCTION GetComponentFillColors(
obj :HANDLE;
componentIndex :INTEGER;
VAR fillForeColor :INTEGER;
VAR fillBackColor :INTEGER) : BOOLEAN;
def vs.GetComponentFillColors(obj, componentIndex):
    return (BOOLEAN, fillForeColor, fillBackColor)

Parameters

obj HANDLE The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
componentIndex INTEGER The index of the component.
fillForeColor INTEGER Returns the fore color of the fill.
fillBackColor INTEGER Returns the back color of the fill.

Version

Availability: from VectorWorks 2008

See Also

VS Functions:

VS:SetComponentFillColors

VS Functions: [[VS:SetComponentFillColors]]