VS:GetCompManualBound

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the manual bound of a component in an object.

FUNCTION GetCompManualBound(
object :HANDLE;
componentIndex :INTEGER;
VAR manualBound :INTEGER) : BOOLEAN;
def vs.GetCompManualBound(object, componentIndex):
    return (BOOLEAN, manualBound)

Parameters

object HANDLE The object. Can be a roof face, roof, Roof Style, or the Roof Preferences.
componentIndex INTEGER The index of the component.
manualBound INTEGER Returns the manual bound of the component. 0 - Roof edge 1 - Roof axis line

Version

Availability: from Vectorworks 2016

See Also

VS Functions:

VS:SetCompManualBound

VS Functions: [[VS:SetCompManualBound]]