VS:GetCompBoundOffset

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the bound offset of a component in an object.

FUNCTION GetCompBoundOffset(
object :HANDLE;
componentIndex :INTEGER;
VAR boundOffset :REAL) : BOOLEAN;
def vs.GetCompBoundOffset(object, componentIndex):
    return (BOOLEAN, boundOffset)

Parameters

object HANDLE The object. Can be a roof face, roof, Roof Style, or the Roof Preferences.
componentIndex INTEGER The index of the component.
boundOffset REAL Returns the bound offset of the component.

Version

Availability: from Vectorworks 2016

See Also

VS Functions:

VS:SetCompBoundOffset

VS Functions: [[VS:SetCompBoundOffset]]