VS:GetClass

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Function GetClass returns the class assigned to the referenced object. None is returned if the object has no class assigned to it.

FUNCTION GetClass(
h :HANDLE) : STRING;
def vs.GetClass(h):
    return STRING

Parameters

h HANDLE Handle to object.

Example

VectorScript

ObjectClass:=GetClass(handleToObject);

Python

ObjectClass = vs.GetClass(handleToObject)

Version

Availability: from All Versions