VS:GetBooleanItem

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Determines if a radio or checkbox button is selected or not.

PROCEDURE GetBooleanItem(
dialogID :LONGINT;
componentID :LONGINT;
VAR outState :BOOLEAN);
def vs.GetBooleanItem(dialogID, componentID):
    return outState

Parameters

dialogID LONGINT the dialog identifier given by CreateLayout or CreateResizableLayout
componentID LONGINT The identifier for the radio or checkbox button component.
outState BOOLEAN True if the button is selected, false otherwise.

Version

Availability: from Vectorworks 2010