VS:GetActivePane

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the currently displayed tab or swap pane in the specified tab or swap control.

This is called from the dialog's event handling routine.

FUNCTION GetActivePane(
dialogID :LONGINT;
tabControlID :LONGINT) : LONGINT;
def vs.GetActivePane(dialogID, tabControlID):
    return LONGINT

Parameters

dialogID LONGINT the ID of the dialog
tabControlID LONGINT the ID of the swap control

Remarks

Note that pane indeces are 1-based in VectorScript, and 0-based in the SDK. Panes are numbered sequentially in the order that they were inserted into the control. This applies to both tab and swap controls

This doesn't return the control ID per se, but rather, the sequential number of the tab or swap pane, in the order in which it was added to the tab/swap control (1, 2, 3, etc.).

Example

Template:ComplexDialogLayout7

Version

Availability: from VectorWorks12.0

See Also

VS Functions:

VS:CreateSwapControl | VS:CreateSwapPane

VS Functions:

[[VS:CreateSwapControl]]

| [[VS:CreateSwapPane]]