VS:EndMXtrd

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure EndMXtrd completes the definition of a multiple extrude object within a VectorWorks document. On calling EndMXtrd, the object is created in the document from the preceding object creation calls.

It is recommended to call ResetOrientation3D after 3D object creations in order to ensure that the new 3D objects will draw properly.

PROCEDURE EndMXtrd;
def vs.EndMXtrd():
    return None

Example

VectorScript

BeginMXtrd(0',1 363/512");
Rect(-125/128",1 113/512",375/512",375/512");
Rect(-25/32",1 113/512",275/512",375/512");
Rect(-75/128",1 113/512",325/1024",375/512");
Locus(-275/2048",125/128");
Rect(-75/128",1 113/512",325/1024",375/512");
Rect(-25/32",1 113/512",275/512",375/512");
Rect(-125/128",1 113/512",375/512",375/512");
EndMXtrd;

Python

vs.BeginMXtrd(0,1 + 363/512)
vs.Rect(-125/128,1 + 113/512,375/512,375/512)
vs.Rect(-25/32,1 + 113/512,275/512,375/512)
vs.Rect(-75/128,1 + 113/512,325/1024,375/512)
vs.Locus(-275/2048,125/128)
vs.Rect(-75/128,1 + 113/512,325/1024,375/512)
vs.Rect(-25/32,1 + 113/512,275/512,375/512)
vs.Rect(-125/128,1 + 113/512,375/512,375/512)
vs.EndMXtrd()

Version

Availability: from All Versions